Matrixformeln als nützliche Helfer in Microsoft Excel

Wer das Wort "Matrix" hört, denkt dabei vielleicht unwillkürlich an komplizierte Formeln für Experten. Doch keine Angst: Matrixformeln in Microsoft Excel sind leicht zu erstellen. Sie beziehen sich – im Gegensatz zu den besser bekannten Einzelwertformeln – auf einen ganzen Zellbereich und ermöglichen es, auch kompliziertere Aufgabenstellungen einfach zu lösen. Tanja Kuhn stellt die prinzipielle Funktionsweise von Matrixformeln vor und gibt einige Anwendungsbeispiele als Anregung.

Wer mit Microsoft Excel arbeitet, kennt vielleicht Matrixformeln. Sie beziehen sich - im Gegensatz zu den besser bekannten Einzelwertformeln - nicht nur auf einzelne Zellen, sondern auf einen ganzen Zellbereich. Möchte man z.B. einen bestimmten Rechenschritt in verschiedenen Zellen durchführen, reicht eine Matrixformel, um das gewünschte Ergebnis zu berechnen. Bild 1 veranschaulicht das Grundprinzip an einem einfachen Beispiel, bei dem der Earned Value für ein Projekt berechnet werden soll. Spalte C enthält die Planwerte für die einzelnen Arbeitspakete, Spalte E den zugehörigen Fertigstellungsgrad. Den Earned Value errechnet man, indem man Planwert und Fertigstellungsgrad für jedes Arbeitspaket multipliziert und die jeweiligen Ergebnisse addiert. Die zugehörige Formel in Zelle B10 lautet:

{=SUMME(C2:C7*E2:E7)}

Die Formel funktioniert folgendermaßen: Zunächst multipliziert sie für jedes Element der Matrix die einzelnen Werte miteinander (also C2*E2; C3*E3; ...) und berechnet anschließend aus den Einzelergebnissen die Summe.

Um eine Matrixformel zu erzeugen, geben Sie die Formel zunächst ohne die geschweiften Klammern ein und schließen die Eingabe dann nicht mit ENTER, sondern mit der Tastenkombination STRG + UMSCHALT + ENTER ab. Excel stellt die Formel dann in geschweiften Klammern dar.

Bild 1: Berechnungen, die sich auf einen Zellbereich beziehen, lassen sich mit Hilfe von Matrixformeln vereinfachen.

Die Anwendungsmöglichkeiten von Matrixformeln beschränken sich nicht auf einfache Berechnungen, wie hier gezeigt. Auch kompliziertere Aufgabenstellungen lassen sich durch Kombination mehrerer Funktionen in einer Matrixformel einfach lösen. Die nachfolgenden Beispiele sollen dafür als Anregung dienen. Wie sich eine Matrixformel z.B. bei der Berechnung eines Mittelwerts verwenden lässt, erklärt der Tipp "Mittelwerte in Exel berechnen - aber richtig" (Ausgabe 12/2008).

Anzeige
Jetzt kostenlos weiterlesen!
Abonnenten des Projekt Magazins wissen mehr!
Starten Sie jetzt unser 4-wöchiges Kennenlern-Angebot: Die Anmeldung dauert nur ein paar Minuten – Sie können also gleich weiterlesen.
  • KostenlosDas Kennenlern-Angebot kostet Sie nichts.
  • Kein RisikoSie können jederzeit kündigen, ohne dass Ihnen Kosten entstehen.
  • Einen Monat lang alles lesen4 Wochen Online-Zugriff auf alle Inhalte des Projekt Magazins.
Tech Link