Mehr Übersicht mit Bereichsnamen & Co. Kampf den "Monsterformeln" in Excel

Unübersichtliche Formeln sind der Horror für Excel-Anwender. Sie sind schwer verständlich und ihre Ergebnisse kaum nachvollziehbar. Besser ist, sie schon beim Tabellenentwurf zu vermeiden, meint Ignatz Schels. Mit ein paar Tricks und dem richtigen Gebrauch von Bereichsnamen bringen Sie schnell Übersicht in den Formel-Dschungel.

 

Mehr Übersicht mit Bereichsnamen & Co. Kampf den "Monsterformeln" in Excel

Unübersichtliche Formeln sind der Horror für Excel-Anwender. Sie sind schwer verständlich und ihre Ergebnisse kaum nachvollziehbar. Besser ist, sie schon beim Tabellenentwurf zu vermeiden, meint Ignatz Schels. Mit ein paar Tricks und dem richtigen Gebrauch von Bereichsnamen bringen Sie schnell Übersicht in den Formel-Dschungel.

 

Sie sind der Horror für Excel-Anwender: Monsterformeln mit zahlreichen Bereichsbezügen, mehrfach geschachtelte WENN()-Funktionen und wüste Aneinanderreihungen von Funktionen. Um sie zu verstehen und die damit beabsichtigten Ergebnisse nachzuvollziehen, bietet sich die Auswertungsfunktion aus der Formelüberwachung an, aber auch diese schafft nicht immer den nötigen Durchblick. Besser ist es, Monsterformeln bereits beim Tabellenentwurf zu vermeiden. Dieser Beitrag zeigt Ihnen, wie Sie Formeln schlanker, lesbarer und verständlicher gestalten.

Bereiche mit Namen versehen

Unübersichtlich und unverständlich werden Formeln hauptsächlich durch die vielen Bezüge, die in den einzelnen Funktionen zum Einsatz kommen. Verwenden Sie konsequent Bereichsnamen an Stelle von Bezügen, wenn diese absolut sind.

Verwenden Sie in Bereichsnamen ausschließlich absolute Bezüge. Relative Bezüge dürfen nicht vorkommen, sie würden abhängig von der Zellzeigerposition berechnet werden.

Das erste Beispiel aus der Praxis zeigt, wie Sie Formeln mit Hilfe von Bereichsnamen deutlich übersichtlicher darstellen können

Ein Kostenbericht mit Monsterformeln

Aus SAP werden monatlich zwei Berichte abgerufen (Bild 1):

  • Eine Liste mit aktuellen Projekten mit dem PSP-Element (Projektnummer) und der Projektbezeichnung.
  • Ein Kostenbericht mit monatlich verfügten Kosten zu den einzelnen Projekten, der neben der Projektnummer u.a. das Datum der Verfügung und den Betrag enthält.

Der Projektleiter hat die Aufgabe, die beiden Berichte zusammenzuführen und fügt dazu eine neue Spalte "Kosten" in den Projektbericht ein. Die Formel soll für jede Projektnummer die Kosten aus dem zweiten Tabellenblatt ermitteln.

Bild 1: Projektliste und verfügte Kosten.

Die Funktion SVERWEIS() löst diese Aufgabe, indem sie für die jeweilige PSP-Nummer in der Projektübersicht den zugehörigen Wert aus der Spalte "Betrag" des Kostenberichts sucht:
=SVERWEIS(A2;'Kosten
verfügt'!$A$1:$F$5;3;FALSCH)

Damit die Funktion auf die richtige Spalte "Betrag" verweist, berechnet eine zweite Funktion VERGLEICH() deren genaue Position:
=VERGLEICH("Betrag";'Kosten verfügt'!$A$1:$F$1;0)

Die Lösung besteht also aus zwei ineinander verschachtelten Funktionen:
=SVERWEIS(A2;'Kosten verfügt'!$A$1:$F$5;VERGLEICH("Betrag";'Kosten verfügt'!$A$1:$F$1;0);FALSCH)

Mit dem gezielten Einsatz von Bereichsnamen entzerren Sie diese Monsterformel und machen sie auch für weniger erfahrene Anwender lesbar.

Bewertungen und Kommentare

Diese Funktion steht nur eingeloggten Nutzern zur Verfügung. Jetzt einloggen
0 Kommentare anzeigen & selbst mitreden!
Gesamt
Bewertungen 4
Kommentare 0