Mittelwerte in Excel berechnen – aber richtig!

Wenn Sie mit Microsoft Excel ein arithmetisches Mittel berechnen möchten, können Sie dafür die "Mittelwert"-Funktion verwenden. Doch diese hat gewisse Eigenheiten – wer sie nicht beachtet, erhält leicht ein falsches Ergebnis. Dieter Schiecke beschreibt, wie Sie Fehler vermeiden und wie Sie mit Hilfe einer Matrixformel auch gewichtete Mittelwerte einfach berechnen können.

Wenn Sie mit Microsoft Excel ein arithmetisches Mittel berechnen möchten (z.B. die durchschnittlichen Projektkosten), können Sie dafür die "Mittelwert"-Funktion verwenden. Doch diese hat gewisse Eigenheiten - wer sie nicht beachtet, erhält leicht ein falsches Ergebnis. Im Folgenden erfahren Sie, wie Sie Fehler vermeiden und wie Sie mit Hilfe einer Matrixformel auch gewichtete Mittelwerte einfach berechnen können.

Das arithmetische Mittel berechnen

Das arithmetische Mittel lässt sich in Excel komfortabel mit der Funktion MITTELWERT(Zahl1; Zahl2; ...) berechnen. Excel berücksichtigt dabei nur numerische Werte als Argumente. Text, Wahrheitswerte (WAHR, FALSCH) oder leere Zellen werden ignoriert.

Bild 1 verdeutlicht das an einem Beispiel. Die auf der linken Seite abgebildete Tabelle zur Halbjahresauswertung enthält neben den Monatsnamen die Werte für die jeweils aufgelaufenen Kosten. Für den Monat Juni wurden die Kosten bisher noch nicht abgerechnet, die entsprechende Zelle B10 bleibt leer. Da Excel leere Zellen bei der Berechnung ignoriert, liefert die Formel =MITTELWERT(B5:B10) den korrekten Mittelwert aus den fünf in Spalte B eingetragenen Werten (Ergebnis: 555,0=2.775:5).

Die Bedeutung der Null berücksichtigen

Beispiel 2 (Bild 1) enthält die gleichen Werte wie Beispiel 1 mit dem Unterschied, dass hier für den fehlenden Juni-Wert eine Null eingetragen wurde. Welche Folge das hat, sehen Sie am Ergebnis in Zelle I11. Das Resultat weicht von dem in D11 ab und beträgt diesmal 462,5. Excel hat in diesem Fall die Zelle G10, die jetzt einen numerischen Wert enthält, bei der Mittelwertberechnung mit berücksichtigt. (Ergebnis: 462,5=2.775:6)

Da Excel zwischen einer leeren Zelle und einem Nullwert unterscheidet, sollten Sie keine Nullen für (noch) fehlende Werte eingeben, wenn Sie den Mittelwert berechnen wollen.

Bild 1: Eine leere Zelle oder eine Null sind für Excel nicht das Gleiche; folglich kommt es zu unterschiedlichen Ergebnissen.

Nullwerte ausschließen

In der Praxis lässt sich die Empfehlung, keine Nullwerte für fehlende Werte einzugeben, allerdings nicht immer umsetzen. Zum Beispiel kann man bei einem Datenimport aus einem Fremdsystem oft nicht verhindern, dass

Anzeige
Jetzt kostenlos weiterlesen!
Abonnenten des Projekt Magazins wissen mehr!
Starten Sie jetzt unser 4-wöchiges Kennenlern-Angebot: Die Anmeldung dauert nur ein paar Minuten – Sie können also gleich weiterlesen.
  • KostenlosDas Kennenlern-Angebot kostet Sie nichts.
  • Kein RisikoSie können jederzeit kündigen, ohne dass Ihnen Kosten entstehen.
  • Einen Monat lang alles lesen4 Wochen Online-Zugriff auf alle Inhalte des Projekt Magazins.
Tech Link